EAC crash in Vista x64

Discussion in 'Exact Audio Copy - English' started by dr_rus, Nov 12, 2008.

  1. dr_rus

    dr_rus New Member

    For some unknown reason EAC has started crashing in Vista x64 when opening any file via standard Windows open file dialog -- the dialog opens, shows the folder tree panel and then... EAC is gone without a trace, no error messages, no processes left in device manager, nothing. This happens if you try to set default folder in Directories tab, split a wav file by cue, provide a path to external compressor in Compression options, etc.

    The thing is that it worked perfectly fine a month ago and now i'm getting this trouble.

    Any ideas what may be the cause? Some new Vista x64 update maybe? Or anything else? All the other programs work with open file dialog just fine...

    I already tried reinstalling it and deleted EAC registry entry -- didn't help.
    I'm using the latest EAC version of course with Vista Ultimate x64 SP1 + all the recommended updates via autoupdater.
    Last edited: Nov 12, 2008
  2. dr_rus

    dr_rus New Member

    Now that's funny but it looks like i found out the reason: the problem is gone after i've fully deinstalled the Adobe CS4 Master Collection... Well... I don't know what to say... =) Probably some kind of conflict with Adobe Drive included in CS4?..
  3. skektek

    skektek New Member

    I think I have the same problem. EAC was running fine under Vista 64-bit, until around the time I installed Adobe CS4 Master Collection. Now the application vanishes as soon as it opens a dialog window for choosing a folder as the extraction target. This makes the application unusable as the first thing a copy operation does is ask you to choose a folder, and bam! - EAC is gone without so much as an error message!

    However, unlike Dr_Rus above, my EAC doesn't crash when it opens a dialog to choose a file - only when it opens a dialog to choose a folder. Perhaps this is related to the uniquely bogus way in which EAC tries to choose a folder - by using a file selection dialog instead of a folder selection dialog, but asking you to ignore the filename. (Like duh! what's that about anyway?)

    There must be a few other people experiencing this problem. Has anyone got any ideas? Workarounds? Otherwise, given that I can't do without CS4, I'll just have to use a different CD ripper. :(
  4. fiskie

    fiskie New Member

    I can confirm that Adobe Drive CS4 is the problem. I had the same problem you stated plus I am also using Vista Business 64-bit as well as Adobe Master Collection CS4.

    Just remove Adobe Drive using the Adobe installer and things should be fine once again!
    You can still use both the applications (except for Drive ofcourse) of the Master Collection as well as EAC :)
    Last edited: Dec 29, 2008
  5. skektek

    skektek New Member

    Easier said than done. Adobe Drive CS4 x64 is installed as a dependency of Photoshop CS4 x64. It cannot be uninstalled without removing Photoshop; at least, not using the Adobe installer anyway.

    Not to be deterred, I uninstalled Adobe Drive manually. First I unregistered the DLLs by running (as administrator)
    Code:
    regsvr32 /u "%CommonProgramFiles%\Adobe\Adobe Drive CS4\ADFSMenu.dll
    regsvr32 /u "%CommonProgramFiles%\Adobe\Adobe Drive CS4\AdobeDriveCS4_NP.dll
    
    Then I ripped all references to "Adobe Drive" out of the registry using regedit, and finally I deleted the C:\Program Files\Common Files\Adobe\Adobe Drive CS4 folder.

    And now EAC works again, and Photoshop seems to get by just fine without Adobe Drive! Thanks for your advice fiskie!
  6. Lund

    Lund New Member

    I have the exact same problem. But I've never installed Adobe Drive becaue I chose not to in the custom installation. Still it gets installed anyway and the shell handlers are registered in Vista x64 even when you've unticked it! Also the Adobe Drive entry was present in Windows Explorer's right-click menu.

    So I first had to unregister the DLLs. Then I had to manually remove them from the registry. Search for keywords and remove all of the keys they're in:

    ADFSMenu.dll
    AdobeDriveCS4_NP.dll

    Because ADFSMenu.dll and BIB.dll are locked you will have to reboot in order to delete the "Adobe Drive CS4" folder. It is not recommended to just kill the explorer processes under Vista and Win7 anymore. ADFSMenu.dll is probably still locked by the current explorer view. Just close and reopen the folder location. But BIB.dll is locked by the main explorer process. You need admin rights to kill it, and restarting it as admin may be a security risk... I'm not an expert, but I'd not take the chance and bet that it will spawn non-admin right processes (like it should do) after being restarted as admin.

    You can restart the main explorer process as a limited user after killing it with admin rights (Process Explorer can do that), but certain stuff may cease to work, i.e. connectivity icon in the notification area will show its offline, when in fact it still works (Windows 7).
    Last edited: Jul 18, 2009
  7. sullidav

    sullidav New Member

    I am having the same problem. EAC was working on 64-bit Win7 system, then not. I do not have this Adobe software installed. I believe there were three changes made since it was working, and I think #1 was the culprit. 1. I deleted the temporary directory that was listed under EAC Options. Later changed the directory to something that existed, but the problem persists. 2. I installed a Windows Hotfix from Microsoft, no. 976972. 3. I updated my Symantec AntiVirus from SEP 11.0.4 to 11.0.5.

    Now when I start EAC, there are two windows that quickly open and close before I can see what they are. If in EAC I run Tools, Compress WAVs, which would normally open a file list to choose, EAC crashes.
  8. sullidav

    sullidav New Member

    Update - it works if I check "disable visual themes" under EAC, Properties, Compatibility tab. Still buggy - clicking on the directory selection bar, instead of the up-directory icon, causes a crash, but enough there to get it working.
  9. traveler137

    traveler137 New Member

    This one was really starting to irritate me. I have been ripping around 70 cds for the last couple of days and been experiencing this same issue but never before.
    I also have recently installed CS4 and clicked to uninstall only Adobe Drive. It worked fine and the problem is gone. No need to go searching through the registry or kill explorer processes :8:
    Thanks for that dr_rus
  10. razorfern

    razorfern New Member

    Confirmed with same problem, Windows 7 x64... ran the Adobe uninstaller, removed Adobe Drive, and EAC stopped crashing.
  11. klapperjr

    klapperjr New Member

    Same problem in Windows 7 Ultimate x64.
    I don't have Adobe CS4 software installed, only Adobe Reader and DLL's ADFSMenu.dll and AdobeDriveCS4_NP.dll not exist in my folders and registry entries.
    Do I have to leave the EAC and use CDex?
  12. pavlos

    pavlos New Member

    I am refreshing the topic, because I can confirm another conflict, mentioned also above. Another - means not the Adobe coflict (I have never installed any Adobe Photoshop).

    I have Win7 x64.
    EAC crashes whenever I open any dialog box with file browser, like "Load configuration, Load cue" etc.

    For particular reasons I had to deinstall Symantec Endpoint Protection.
    After removing SEP, I have checked EAC and ...it worked!!! I have ripped and burned a CD without problems!

    After installing SEP back, the problem with EAC crashing had returned.

    For particular reasons I have to use SEP, so I remain without EAC on my Win7 box...

    As a workaround, I have created a small WinXP virtual machine with VMware Player (the latest version allows you to create new virtual machines). Installed EAC there. It works this way.

    QUESTION: can anybody else confirm that EAC conflicts with SEP on Win7 x64 box?
  13. Fætter

    Fætter New Member

    sullidav's fix works

    Yes. I have this exact problem.
    Yes, I have Symantec Endpoint Protection installed.

    It still crashes if you disable SEP.

    But sullidav's fix works for me.
    In Task Manager under processes, select the EAC process and right click, under Properties, Compatibility tab check "disable visual themes". And restart EAC.
    Last edited: Oct 14, 2010
  14. pavlos

    pavlos New Member

    Disabling SEP is not enough. EAC still crashes. Only full SEP uninstall helps.
    Disabling visual themes doesn't help me either.

    As I mentioned - my workaround with (free) VMware Player is enough for me.
  15. chazj

    chazj New Member

    One easy work around: change the temp folder in the EAC options to an existing folder. For example, I created one on my desktop (called EAC) and set it to c:\Users\*username*\Desktop\EAC.

    As long as you're willing to live with all the cue sheets and files being created in that folder, it should work.
  16. h2de5

    h2de5 New Member

    What i did to rectify the problem was uninstall Adobe Drive CS4. When you go to uninstall the whole adobe suite it will then ask you on the next screen what do you want to uninstall.. eg. photoshop, dreamever, etc..

    Just choose Adobe Drive CS4

    Problem solved.

    I am running Win 7 64 bit
  17. Erac

    Erac New Member

    I have the same problem with EAC V1.0 beta 3 crashing in any folder dialog on Win 7 Enterprise 64 with SEP. No Adobe Software at all was installed ever.
    "Disable visual themes" doesn't help. Uninstalling SEP is no option and I don't like to start a VM only because of this.

    Is there any chance that this bug can be fixed? Any idea why it happens?
  18. Erac

    Erac New Member

Share This Page