EAC crashes on Windows 7

Discussion in 'Exact Audio Copy - English' started by aleks, Feb 10, 2013.

  1. aleks

    aleks New Member

    I have bought a new computer - Dell XPS 8500 with Windows 7 Home Premium 64 bit. I have installed EAC V1.0 beta 3 and it crashes every time I try to use it. I run the EAC.exe compatible with Windows XP SP3 and run it as administrator.

    Copy Selected Tracks - OK
    Test & Copy Selected Tracks - OK
    Copy Range - EAC.exe has stopped working
    Test Selected Tracks - OK
    Copy Image & Create CUE Sheet - EAC.exe has stopped working
    Test & Copy Image & Create CUE Sheet - EAC.exe has stopped working

    Sometimes when I try to copy image, I see a "Save Waveform" dialog, but the "EAC.exe has stopped working" message pops up right away.

    I have tried older versions of EAC without any success.

    Does anybody knows what might be wrong and what else can I try?
  2. jimzzzak

    jimzzzak New Member

    I hope it works on my new Win 7 machine. It's Win 7 Pro 64.
  3. DerNico

    DerNico New Member

    Since the last Win7 update I have the same problem. On 15. februar I ripped a cd successfully, today EAC crashes every time. I'm working under Win7 Pro 64. I also tried to set the compatibily mode for EAC with no effect.
  4. mepiazza

    mepiazza New Member

    I have been having the exact same problem on both of the Windows 7 x64 machines I have tried it on. Windows, in its ultimate stupidity, cannot provide a fix because EAC in its complete lack of helpfulness doesn't even generate an error message. It just says it crashes and then goes away. In this day and age there is NO EXCUSE for that kind of program behavior. Those errors should be handled with at least a generic exception if nothing else. Give us a dump of the exception so maybe we have a chance of figuring out what is going on.

    Whether it is something Microsoft has done to the Windows code base or not, as of now this program has been rendered completely USELESS!

    I guess I'm going to have to write my own version of a program that has EAC's functionality and incorporating, at least at first, those functions that I use. I cannot depend on EAC anymore. Sad really.
  5. Surfy

    Surfy Member Deluxe

    ::

    First of all:

    Neither use any Windows compatibility options nor start EAC as Administrator!


    Try these:

    1. Make sure not to have "Adobe Drive" installed (comes with CS5 e.g.).

    2. If you have TortoiseSVN and/or TortoiseGit client installed:
    Check "Show overlays and context menu only in explorer" option in Tortoise's "Icon Overlays" settings pane. ​


    3. Stop/quit EAC. Get an updated "cygwin1.dll".
    (You'll find a binary in an archive here, e.g..)
    Rename "cygwin1.dll" in EAC's subfolder "CDRDAO" to "cygwin1.old" or delete it.
    Unpack new "cygwin1.dll" to "CDRDAO"​


    4. Stop/quit EAC. Get and copy Ahead ASPI to EAC's folder.
    Start EAC, press "F9", select "Interface" tab and switch to "Installed external ASPI interface".
    Restart EAC and try again. ​


    5. In EAC's menu select "File - EAC Options". Click the "Directories" tab.
    Switch to "Use this directory" and choose a directory you have write permissions for. ​



    Regards, ... :awayaway:

    ::
    Last edited: Mar 3, 2013
  6. poppadum

    poppadum New Member

    Many thanks - that fixed my Unhandled Exception at X -> Access_Violation errors when opening a file dialog (e.g. Load Configuration Profile)
  7. mepiazza

    mepiazza New Member

    OK I went through everything except Adobe Drive ( I do have CS5 but it was working fine before and I haven't touched that). I made the change to the TortoiseSVN (although i don't think that that was the cause of the problem either). What had changed is that in my most recent rebuild, I finally set up my drives using ASPI as I am no longer dual-booting with XP. I had thought I had successfully run EAC since my system rebuild but I guess not. I believe it was the Ahead ASPI driver and the reconfiguration, as described above, to use it that allowed it to work again.

    If you had provided an exception handler for that error I may have twigged to the problem with the change to an ASPI disk interface configuration, although I still would have been without a solution file. As it is I thank you for the solution and the link to the required files.
  8. BeLe

    BeLe New Member

    I had to grab gssapi32.dll from somewhere and throw it in my EAC dir.

Share This Page