Using EAC with Windows 7 64 bit?

Discussion in 'Exact Audio Copy - English' started by alokeprasad, Jan 9, 2011.

  1. alokeprasad

    alokeprasad New Member

    Any special instructions/tips for using EAC on a Windows 7 64 bit system?

    Which version should I use?

    How do I use it with MP3 encoding by LAME?

    Thanks.
    Aloke
  2. bkzz

    bkzz New Member

    Problems in Windows 7, 64-bit

    I am upgrading from EAC running on Windows Vista 64-bit. I have used several versions of EAC for years without problems and was using 0.99pb4 on Vista.

    I setup a new computer with Windows 7, Version 6.1.7600 Build 7600 and the DVD/CD is an LG WH10LS30 on SATA port with Blu-Ray capabilities. The motherboard is a Gigabyte based on the Intel P45 chipset, and I have 8GB RAM and the Intel Q9550 quad-core. I downloaded EAC 1.00beta1 to install. Everything acted normal through the installation and configuration, but when I tried my first rip, the "Extracting Audio Data" window popped up and nothing happened. The EAC application wouldn't cancel, was unresponsive, and I had to force terminate from the Task Manager, which left the drive in a state where it wouldn't eject, so I had to reboot, too.

    I tried numerous things I read on this forum. I installed wnaspi32.dll, version 2.0.1.74 from Nero and configuring to use it. Configured to write in a specific existing directory rather than "ask every time". Run in Vista SP2 compatibility mode, XP SP3 compatibility mode, Disable Desktop Composition. I also just tried extracting to .WAV, so that lame could not be an issue. None of these made any difference in the behavior. I plugged in an I/O magic USB DVD burner that I owned to see if it was a drive-specific issuce. No change in behavior.

    I finally removed EAC 1.00beta1 and downloaded and installed EAC 0.99pb5. Configuration for both drives went normally. I could use the USB drive to rip, but the "Extracting Audio Data" window would disappear and then reappear in a slightly different spot repeatedly during the extraction, and extraction was only in the 1.8x range for the USB drive. I set Windows Vista SP2 compatibility mode on the shortcut, and the window stabilized, but performance is in the 2x range, which is not great but may be all that the USB drive can do, because I haven't used it for EAC before. Once I set the Vista compatibility mode, I can get the SATA drive to rip in the .7x to 1.3x range, which is pretty bad. The SATA drive in my Vista box would typically rip at 7x-8x in secure mode.

    I liked the cover download feature in 1.00, but haven't been able to get that version to rip CD's at all, and I am trying to figure out whether I need to get a different drive to get decent rip speeds with v.99.
  3. alokeprasad

    alokeprasad New Member

    I just installed EAC 1.0 B1 and LAME 3.98.4 64 bit. Everything went smoothly and I am having no problems whatsoever.

    How do I set the offsets for my drives? Is there an ISO that I can burn and use? A database of offsets?

    [Edit: I spoke too soon!! EAC launched correctly after installation. I am getting the following error when I start the program manually:

    Unhandled Exception at 00B310DE -> ACCESS_VIOLATION
    Last edited: Jan 10, 2011
  4. alokeprasad

    alokeprasad New Member

    Found solution here by searching.

    Move LAME files (exe and DLL) to a different directory.
  5. Surfy

    Surfy Member Deluxe

    EAC with Win 7 x64

    ::

    Did you install IntelĀ® Rapid Storage Technology
    for Intel Series 4 Desktop chipsets?

    There's no problem here on Win 7 x64. I'd use LAME x86 because it's faster than the x64 version.
    Oh, and it should reside in EAC's folder because it needs to be there for being used for decoding.


    Greetings Surf ...

    ::
  6. bkzz

    bkzz New Member

    I am running a RAID-0 stripe on two of the Intel SATA ports. I don't distinctly remember downloading the latest Intel Rapid Storage, but I had to load drivers to complete the install.

    I have a list of things to try when I get some time. The problems seem to focus around the GUI behavior (which makes me wonder if other using Win 7 64 successfully are using any of the compatibility settings) and the LG SATA drive. The USB drive works about the same on both Vista and Win 7 with EAC v.99.

    I still have the Vista computer available, so I can try EAC 1.0 on it, and I could even move the LG drive over to see how it runs with EAC under Vista. I have seen other complaints about the slowness of the LG drive with EAC.
  7. bkzz

    bkzz New Member

    More data on Windows 7

    Loaded Windows 7 on my old computer (switched out the hard drive so that I could go back to Vista if I need to). The SATA DVD drive on it is the TSSTcorp SH-S223Q. Installed EAC 1.0beta 1 before I loaded anything else. The drive configured from database settings (AccurateStream and C2 yes, caching no). Did not set any compatibility settings on the EAC desktop shortcut.

    It ripped a CD fine at an average 8x. No strange window behavior or anything. So something else in my new Windows 7 installation is interfering with EAC 1.0.

    If and when I figure out what it is, I will post.
  8. bkzz

    bkzz New Member

    I still haven't figured it out, and have spent days on it.

    In trying to identify the differences between the working and non-working Windows 7 installation, I think the significant one is that the non-working one is a "Professional" and the working one is a "Home Premium". Professional and Ultimate add Local Security Policy configuration and I am guessing that one of the default policies is preventing access to the drive, but this is just a guess.

    I have tried installing and uninstalling software applications between the two systems to try to insure there is not a driver/dll difference that is causing the failure, and EAC seems to be picking up the same dll's on both. It does appear that there is a small memory leak in EAC 1.0beta1, where it repeatedly allocates a new Key for the HKCU\Software\CDCoverDownloader, but this happens on both systems.
  9. phoenix100

    phoenix100 New Member

    I have the problem as you (I use win7x64 , ultimate )and also have had to revert to EAC 0.99pb5 to get a working app. My only doubt is holding a local policy responsible , in switching between eac versions the policy isn't changing so really this is eac's problem. Sorry if that sounds a bit judgemental for a free , and very good program, but really the only people who can fix this is EAC. Let's hope they do so soon.

Share This Page